summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-21 18:35:11 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-21 18:35:11 +0000
commit65c34da02b525ba4f22d052f383e5c072dd1bb29 (patch)
tree0454743df38df2177b3c35a3ab00cc28b452b75f /c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am
parent2001-11-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-65c34da02b525ba4f22d052f383e5c072dd1bb29.tar.bz2
2001-11-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add @exceptions@ to SUBDIRS. * configure.ac: Apply RTEMS_BSPOPTS_*(*) to merge-in settings from make/custom/score603e.cfg; Add automake conditional for SCORE_GENERATION_1; Add RTEMS_PPC_EXCEPTIONS([old]). * include/Makefile.am: include force-preinstall.am. * start/start.S: include <bspopts.h> instead of targopts.h. * tod/Makefile.am: Apply SCORE_GENERATION_1 conditional. * vectors/vector.S: include <bsp.h>. * wrapup/Makefile.am: Apply @exceptions@.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am b/c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am
index 1c8da28111..938dfa502c 100644
--- a/c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/score603e/tod/Makefile.am
@@ -11,10 +11,12 @@ include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
# generation 1
-TOD_C_FILES_1_V = tod_g1.c
+if SCORE603E_GENERATION_1
+TOD_C_FILES = tod_g1.c
+else
# generation 2
-TOD_C_FILES_2_V = tod.c
-TOD_C_FILES = $(TOD_C_FILES_$(SCORE603E_GENERATION)_V)
+TOD_C_FILES = tod.c
+endif
C_FILES = $(TOD_C_FILES)
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)