summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-06 17:36:54 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-06 17:36:54 +0000
commit37064d8139be4c6a756418bc12f22bdb67ff63d0 (patch)
treed46a16a5c3d4af21b4f00e379e98764853d9a1b7 /c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
parent2004-02-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-37064d8139be4c6a756418bc12f22bdb67ff63d0.tar.bz2
2004-02-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* wrapup/Makefile.am: Convert to automake-building rules.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
index b7a8c14dcb..655c018a52 100644
--- a/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/psim/wrapup/Makefile.am
@@ -3,19 +3,23 @@
##
include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-OBJS = ../startup$(LIB_VARIANT).rel ../clock$(LIB_VARIANT).rel \
+EXTRA_LIBRARIES = ../libbsp.a
+CLEANFILES = ../libbsp.a
+___libbsp_a_SOURCES =
+___libbsp_a_LIBADD = ../startup$(LIB_VARIANT).rel ../clock$(LIB_VARIANT).rel \
../console$(LIB_VARIANT).rel ../timer$(LIB_VARIANT).rel \
../vectors$(LIB_VARIANT).rel
if HAS_MP
-OBJS += ../shmsupp$(LIB_VARIANT).rel
+___libbsp_a_LIBADD += ../shmsupp$(LIB_VARIANT).rel
endif
-OBJS += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel
+___libbsp_a_LIBADD += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel
-$(ARCH)/libbsp.a: $(OBJS)
- $(make-library)
+EXTRA_LIBRARIES += ../libbsp_g.a
+CLEANFILES += ../libbsp_g.a
+___libbsp_g_a_SOURCES = $(___libbsp_a_SOURCES)
+___libbsp_g_a_LIBADD = $(___libbsp_a_LIBADD)
-noinst_DATA = $(ARCH)/libbsp.a
+noinst_DATA = ../libbsp$(LIB_VARIANT).a
include $(top_srcdir)/../../../../automake/local.am