summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 16:22:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 16:22:28 +0000
commitac73276b1e1be22d5e5f38c30dab57e52c724618 (patch)
tree47a15cb127934aeb7119b36452ea31428d11c1ba /c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ac73276b1e1be22d5e5f38c30dab57e52c724618.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, shmsupp/Makefile.am, startup/Makefile.am, timer/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, shmsupp/Makefile.am, startup/Makefile.am, timer/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/startup/Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am b/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
deleted file mode 100644
index a4f6e845a4..0000000000
--- a/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-##
-## $Id$
-##
-
-PGM = $(ARCH)/startup.rel
-
-C_FILES = bspclean.c bspstart.c setvec.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-shared_C_FILES = $(top_srcdir)/../../shared/bootcard.c
-shared_C_FILES += $(top_srcdir)/../../shared/bsplibc.c
-shared_C_FILES += $(top_srcdir)/../../shared/bsppost.c
-shared_C_FILES += $(top_srcdir)/../../shared/main.c
-shared_C_FILES += $(top_srcdir)/../../shared/sbrk.c
-shared_C_FILES += $(top_srcdir)/../../shared/gnatinstallhandler.c
-OBJS += \
- $(shared_C_FILES:$(top_srcdir)/../../shared/%.c=$(ARCH)/%.$(OBJEXT))
-
-$(ARCH)/%.$(OBJEXT): $(top_srcdir)/../../shared/%.c $(ARCH)/$(dirstamp)
- ${COMPILE} -o $@ -c $<
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-project_lib_DATA = linkcmds device-tree
-
-all-local: $(PGM) $(TMPINSTALL_FILES)
-
-EXTRA_DIST = bspclean.c bspstart.c device-tree linkcmds setvec.c
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-$(PROJECT_LIB)/device-tree: device-tree $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/device-tree
-TMPINSTALL_FILES += $(PROJECT_LIB)/device-tree
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am