summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:43 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:43 +0000
commit4b27d816f3531a75a4ffeef9be81db2248ef9aa4 (patch)
tree0eca5c79a86c87b663145652ca1916da77256710 /c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
parent2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4b27d816f3531a75a4ffeef9be81db2248ef9aa4.tar.bz2
2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * startup/linkcmds: Preparations for gcc-3.3.x. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/startup/Makefile.am21
1 files changed, 9 insertions, 12 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am b/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
index 40a181d2db..39c58d2c3e 100644
--- a/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/psim/startup/Makefile.am
@@ -22,21 +22,18 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds device-tree
+project_lib_DATA = linkcmds device-tree
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+all-local: $(PGM) $(TMPINSTALL_FILES)
-$(PROJECT_RELEASE)/lib/device-tree: device-tree
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds \
- $(PROJECT_RELEASE)/lib/device-tree
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
+EXTRA_DIST = bspclean.c bspstart.c device-tree linkcmds setvec.c
-.PRECIOUS: $(PGM)
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
-EXTRA_DIST = bspclean.c bspstart.c device-tree linkcmds setvec.c
+${PROJECT_RELEASE}/lib/device-tree: device-tree ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/device-tree
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/device-tree
include $(top_srcdir)/../../../../automake/local.am