summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 02:09:37 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 02:09:37 +0000
commit59d464015289ae4618dbd636f6eb180d90fdfde8 (patch)
treee1da85cb3e89b9dbb401dc705d722b1bbb90dfb7 /c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am
parent2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-59d464015289ae4618dbd636f6eb180d90fdfde8.tar.bz2
2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, network/Makefile.am, nvram/Makefile.am, pci/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, universe/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, network/Makefile.am, nvram/Makefile.am, pci/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, universe/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am
index 9516f200a2..f78a03efaa 100644
--- a/c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/ppcn_60x/wrapup/Makefile.am
@@ -2,17 +2,16 @@
## $Id$
##
-# We only build the network device driver if HAS_NETWORK was defined
+OBJS = ../startup$(LIB_VARIANT).rel ../clock$(LIB_VARIANT).rel \
+ ../console$(LIB_VARIANT).rel ../timer$(LIB_VARIANT).rel \
+ ../tod$(LIB_VARIANT).rel ../nvram$(LIB_VARIANT).rel \
+ ../universe$(LIB_VARIANT).rel ../pci$(LIB_VARIANT).rel \
+ ../vectors$(LIB_VARIANT).rel
if HAS_NETWORKING
-NETWORK = network
+OBJS += ../network$(LIB_VARIANT).rel
endif
-BSP_PIECES = startup clock console timer tod $(NETWORK) nvram universe pci \
- vectors
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel
+OBJS += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am