summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mvme5500/configure.ac
diff options
context:
space:
mode:
authorPeter Dufault <dufault@hda.com>2021-04-27 13:48:46 -0400
committerVijay Kumar Banerjee <vijay@rtems.org>2021-04-27 16:46:48 -0600
commit9c13e528a003028af27365b6894af85836d804a1 (patch)
treef1ec6b8ab12805fa4c8091ec00c4b30b676453a4 /c/src/lib/libbsp/powerpc/mvme5500/configure.ac
parentReturn status code for _Thread_Start() (diff)
downloadrtems-9c13e528a003028af27365b6894af85836d804a1.tar.bz2
powerpc/shared/console: Make console baud rate configurable.
The "powerpc/shared/console" code has the start-up console value fixed at 9600 baud. This changes the hard-wired constant "9600" in the code to the configuration setting "BSP_CONSOLE_BAUD" and adds configuration support in both the "waf" and the legacy configuration systems. Note that the VME BSPs beatnik, mvme3100, and mve5100 can be improved by adding a "mvmexxxx" BSP family. This configuration change, as well as future configuration changes, could then be made in a "grp.yml" file.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mvme5500/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/mvme5500/configure.ac b/c/src/lib/libbsp/powerpc/mvme5500/configure.ac
index a1910ca562..76ce4057e8 100644
--- a/c/src/lib/libbsp/powerpc/mvme5500/configure.ac
+++ b/c/src/lib/libbsp/powerpc/mvme5500/configure.ac
@@ -33,6 +33,10 @@ Note that the policy can still be defined by the application
CONFIGURE_MALLOC_BSP_SUPPORTS_SBRK this feature is removed
and a little memory is saved.])
+RTEMS_BSPOPTS_SET([BSP_CONSOLE_BAUD],[*],[9600])
+RTEMS_BSPOPTS_HELP([BSP_CONSOLE_BAUD],
+[default console baud])
+
AC_DEFINE(mpc7455, 1, [PowerPC model option])
RTEMS_BSP_CLEANUP_OPTIONS