summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
diff options
context:
space:
mode:
authorTill Straumann <strauman@slac.stanford.edu>2005-11-03 21:38:36 +0000
committerTill Straumann <strauman@slac.stanford.edu>2005-11-03 21:38:36 +0000
commit7e2dcde9c19c067c37c98891df60cc9d274845fc (patch)
tree3984cd546a36ccc0b88f375e4bbd2dd6c42081fb /c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
parent2005-11-03 straumanatslacdotstanforddotedu (diff)
downloadrtems-7e2dcde9c19c067c37c98891df60cc9d274845fc.tar.bz2
2005-11-03 straumanatslacdotstanforddotedu
* startup/linkcmds: Removed. * Makefile.am, start/preload.S, startup/bspstart.c: use linkcmds from shared area - this version seemed broken anyways. Let the preloader use the generic 'entry_point_section' rather than its own 'mvme5500_preloader_section'. Also, let zero_bss use (implicit?) __SBSSxxx__ symbols.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mvme5500/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am b/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
index 04383df66b..fe3640377f 100644
--- a/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
@@ -21,7 +21,7 @@ noinst_PROGRAMS =
include_bspdir = $(includedir)/bsp
###
-dist_project_lib_DATA += startup/linkcmds
+dist_project_lib_DATA += ../shared/startup/linkcmds
# UNUSED
EXTRA_DIST = startup/bootpstuff.c
@@ -187,7 +187,7 @@ $(PROJECT_INCLUDE)/bsp/$(dirstamp):
@: > $(PROJECT_INCLUDE)/bsp/$(dirstamp)
PREINSTALL_DIRS += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
-$(PROJECT_LIB)/linkcmds: startup/linkcmds $(PROJECT_LIB)/$(dirstamp)
+$(PROJECT_LIB)/linkcmds: ../shared/startup/linkcmds $(PROJECT_LIB)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
PREINSTALL_FILES += $(PROJECT_LIB)/linkcmds