summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 09:45:36 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 09:45:36 +0000
commitd58c0ffc66ab95ed381f9b1f58ce405fbffe91d9 (patch)
tree83de7575293a5a5f27a903df7ea66b9e53e7d1ff /c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
parent2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d58c0ffc66ab95ed381f9b1f58ce405fbffe91d9.tar.bz2
2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/.cvsignore, console/.cvsignore, irq/.cvsignore, network/.cvsignore, startup/.cvsignore, vectors/.cvsignore. Use automake compilation rules. * clock/.cvsignore, console/.cvsignore, irq/.cvsignore, network/.cvsignore, startup/.cvsignore, vectors/.cvsignore: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
index 5f58713886..807ad6119b 100644
--- a/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mpc8260ads/wrapup/Makefile.am
@@ -2,16 +2,17 @@
## $Id$
##
-# We only build the networking device driver if HAS_NETWORKING was defined
+OBJS = ../pclock$(LIB_VARIANT).rel ../irq$(LIB_VARIANT).rel \
+ ../startup$(LIB_VARIANT).rel \
+ ../console$(LIB_VARIANT).rel ../vectors$(LIB_VARIANT).rel
+
if HAS_NETWORKING
-NETWORKING = network
+OBJS += ../network$(LIB_VARIANT).rel
endif
-BSP_PIECES = clock irq start startup console vectors $(NETWORKING)
-
# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- $(wildcard ../../../../libcpu/powerpc/shared/*/$(ARCH)/*.$(OBJEXT)) \
+OBJS += ../../../../libcpu/powerpc/shared/cpuIdent$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/shared/cache$(LIB_VARIANT).rel \
../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
../../../../libcpu/powerpc/mpc8260/clock$(LIB_VARIANT).rel \
../../../../libcpu/powerpc/mpc8260/console-generic$(LIB_VARIANT).rel \