summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-16 19:06:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-16 19:06:45 +0000
commite76068d31feda0483fb2a83fcafe366c08dfc76c (patch)
tree203af67b4834dc0aad94da9a3b2f253fc17c6f53 /c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
parent2008-09-16 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-e76068d31feda0483fb2a83fcafe366c08dfc76c.tar.bz2
2008-09-16 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, startup/bspstart.c: Add use of bsp_get_work_area() in its own file and rely on BSP Framework to perform more initialization. Remove unnecessary includes of rtems/libio.h and rtems/libcsupport.h. * startup/bspgetworkarea.c: New file.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am b/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
index c2592e6f0f..d5ed464900 100644
--- a/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
@@ -42,7 +42,7 @@ include_bsp_HEADERS = include/mpc55xxevb.h \
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
../../shared/bootcard.c ../shared/src/tictac.c ../../shared/bspclean.c \
- startup/bspstart.c ../../shared/bsppretaskinghook.c
+ startup/bspstart.c startup/bspgetworkarea.c ../../shared/bsppretaskinghook.c
clock_SOURCES = ../shared/clock/clock.c