summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 20:52:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 20:52:22 +0000
commit81ec50442dacc498cc69106cbec689028f2094df (patch)
tree076d631792c5306c5f0b71447922bab7b17175b1 /c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
parent2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-81ec50442dacc498cc69106cbec689028f2094df.tar.bz2
2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am: Eliminate bsp.am. Build startup files as side-effect of building libbspstart.a, using automake-rules.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am b/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
index 97d2586ead..63b6eb1007 100644
--- a/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mpc55xxevb/Makefile.am
@@ -5,7 +5,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
include_bspdir = $(includedir)/bsp
@@ -16,21 +15,17 @@ DISTCLEANFILES = include/bspopts.h
noinst_PROGRAMS =
-# Object files
-EXTRA_DIST = startup/start.S
-start.$(OBJEXT): startup/start.S
- $(CPPASCOMPILE) -o $@ -c $<
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = startup/start.S
project_lib_DATA = start.$(OBJEXT)
-EXTRA_DIST += ../shared/start/rtems_crti.S
-rtems_crti.$(OBJEXT): ../shared/start/rtems_crti.S
- $(CPPASCOMPILE) -o $@ -c $<
+libbspstart_a_SOURCES += ../shared/start/rtems_crti.S
project_lib_DATA += rtems_crti.$(OBJEXT)
# Link commands
dist_project_lib_DATA += startup/linkcmds startup/linkcmds.memory
-noinst_LIBRARIES = libbsp.a
+noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
# Includes