summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:27 +0000
commit518ce3925edc55cbb79744c8cf918d43b135f71d (patch)
tree7c1a5f1f9253376dcc2af9a6d1a9a8f02727acfd /c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
parent2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-518ce3925edc55cbb79744c8cf918d43b135f71d.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS. * irq/Makefile.am: Add PREINSTALL_DIRS. * motorola/Makefile.am: Add PREINSTALL_DIRS. * openpic/Makefile.am: Add PREINSTALL_DIRS. * pci/Makefile.am: Add PREINSTALL_DIRS. * vectors/Makefile.am: Add PREINSTALL_DIRS. * vme/Makefile.am: Add PREINSTALL_DIRS. * wrapup/Makefile.am: Reflect changes to libcpu.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
index 6dab163b14..0ba4fe2a66 100644
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
@@ -21,17 +21,19 @@ noinst_DATA = $(OBJS)
all-local: $(PREINSTALL_FILES)
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/bsp/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/bsp
@: > $(PROJECT_INCLUDE)/bsp/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
$(PROJECT_INCLUDE)/bsp/openpic.h: $(top_srcdir)/../../powerpc/shared/openpic/openpic.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/openpic.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/openpic.h
CLEANFILES = $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../../automake/local.am