summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
new file mode 100644
index 0000000000..be3141a744
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/openpic/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../shared/openpic
+
+C_FILES = openpic.c
+
+H_FILES = ../../shared/openpic/openpic.h
+
+OBJS = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+$(PROJECT_INCLUDE)/bsp:
+ $(mkinstalldirs) $< $@
+
+$(PROJECT_INCLUDE)/bsp/openpic.h: ../../shared/openpic/openpic.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp $(PROJECT_INCLUDE)/bsp/openpic.h
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS)
+
+include $(top_srcdir)/../../../../../../automake/local.am