summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am
new file mode 100644
index 0000000000..59e52de5c3
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/motorola/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../shared/motorola
+
+C_FILES = motorola.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+# FIXME: This doesn't give any sense here
+H_FILES = ../../shared/motorola/motorola.h
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS)
+
+include $(top_srcdir)/../../../../../../automake/local.am