summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/include/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:22:48 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:22:48 +0000
commit23090f33860ae60badb5eb6e781e99a79801720a (patch)
tree1fbc8b5584aac3f3e51cf2861ad22d97bbc9aba2 /c/src/lib/libbsp/powerpc/motorola_powerpc/include/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-23090f33860ae60badb5eb6e781e99a79801720a.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * include/bsp.h: Add copy of ../shared/include/bsp.h (Violates BSP coding standards). * configure.ac: Reflect changes above. * irq/Makefile.am: Fix header installation. * motorola/Makefile.am: Fix header installation. * openpic/Makefile.am: Fix header installation. * pci/Makefile.am: Fix header installation.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/include/Makefile.am59
1 files changed, 0 insertions, 59 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/include/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/include/Makefile.am
deleted file mode 100644
index 6622c39664..0000000000
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/include/Makefile.am
+++ /dev/null
@@ -1,59 +0,0 @@
-##
-## $Id$
-##
-
-include_HEADERS = bspopts.h
-
-include_HEADERS += ../../shared/include/nvram.h ../../shared/include/bsp.h \
- ../../../shared/include/coverhd.h
-
-include_bspdir = $(includedir)/bsp
-include_bsp_HEADERS = ../../shared/console/consoleIo.h ../../shared/console/uart.h \
- ../../shared/irq/irq.h ../../shared/motorola/motorola.h
-
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/bsp:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/nvram.h: ../../shared/include/nvram.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp.h: ../../shared/include/bsp.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/consoleIo.h: ../../shared/console/consoleIo.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/uart.h: ../../shared/console/uart.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/irq.h: ../../shared/irq/irq.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/motorola.h: ../../shared/motorola/motorola.h
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES = $(PROJECT_INCLUDE)
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bspopts.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bsp.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/nvram.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
-
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bsp
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/motorola.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/consoleIo.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/uart.h
-TMPINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/irq.h
-
-all-local: $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/force-preinstall.am
-include $(top_srcdir)/../../../../automake/local.am