summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2004-11-10 23:50:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2004-11-10 23:50:48 +0000
commitf9877d257769bd19f38189024fc38b14fe5460ca (patch)
treeec627f3578b388f153d090a42167f22da9548e72 /c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
parent2004-11-10 Richard Campbell <richard.campbell@oarcorp.com> (diff)
downloadrtems-f9877d257769bd19f38189024fc38b14fe5460ca.tar.bz2
2004-11-10 Richard Campbell <richard.campbell@oarcorp.com>
* Makefile.am, configure.ac, bootloader/Makefile.am, include/bsp.h, wrapup/Makefile.am: Add MVME2100 BSP and MPC8240 support. There was also a significant amount of spelling and whitespace cleanup. * README.MVME2100: New file.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac b/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
index c7b2bc9916..115828ebe4 100644
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
@@ -31,6 +31,16 @@ RTEMS_BSPOPTS_HELP([PPC_USE_DATA_CACHE],
of PowerPC 603e revisions and emulator versions.
The BSP actually contains the call that enables this.])
+RTEMS_BSPOPTS_SET([mvme2100],[mvme2100],[1])
+RTEMS_BSPOPTS_SET([mvme2100],[*],[])
+RTEMS_BSPOPTS_HELP([mvme2100],
+[Defined for MVME2100 -- undefined for others])
+
+RTEMS_BSPOPTS_SET([mpc8240],[mvme2100],[1])
+RTEMS_BSPOPTS_SET([mpc8240],[*],[])
+RTEMS_BSPOPTS_HELP([mpc8240],
+[Defined for boards with MPC8240 -- undefined for others])
+
## HACK: This should better be propagated through the BSP's bsp.h.
## however, this BSP doesn't have one :(
AC_DEFINE_UNQUOTED([USE_ENHANCED_INTR_API],[1],