summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am
new file mode 100644
index 0000000000..8e43957699
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/bootloader/Makefile.am
@@ -0,0 +1,65 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../../shared:@srcdir@/../../shared/console:@srcdir@/../../shared/bootloader
+
+C_FILES = misc.c pci.c zlib.c mm.c em86.c polled_io.c lib.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+H_FILES = bootldr.h zlib.h pci.h
+
+S_FILES = head.S exception.S em86real.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(S_O_FILES) $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D__BOOT__ -DDEBUG
+AM_CFLAGS += -msoft-float -mstrict-align -fno-builtin -Wall -mmultiple \
+ -mstring -O2 -fomit-frame-pointer -mrelocatable -ffixed-r13 -mno-sdata \
+ -D__BOOT__ -DDEBUG
+
+ASFLAGS += -mrelocatable
+
+IMAGES = rtems.gz
+
+CLEANFILES += bootloader reloc.O
+DISTCLEANFILES += $(IMAGES)
+
+#
+# CAUTION :
+#
+# As we use very specific compilation options in this directory
+# we shall not use any other code. This includes the newlib libc.a
+# as well as other code located in .o files in mcp750 directory.
+#
+# NEVER remove lib.c. You have been warned...
+#
+bootloader : $(OBJS) $(IMAGES) $(BINARY_LOADED) ppcboot.lds
+ $(LD) -o bootloader $(OBJS) --just-symbols=$(BINARY_LOADED) \
+ -b binary $(IMAGES) -T @srcdir@/../../shared/bootloader/ppcboot.lds \
+ -Map bootloader.map
+
+check_unresolved : $(OBJS)
+ $(LD) -r -o reloc.O $(OBJS)
+ $(NM) reloc.O |grep ' U '
+ echo "Every symbol listed should be defined in @srcdir@/ppcboot.lds"
+
+rtems: $(BINARY_LOADED)
+ $(OBJCOPY) $(BINARY_LOADED) rtems -O binary -R .comment -S
+
+rtems.gz: rtems
+ gzip -vf9 rtems
+
+all-local: $(ARCH) $(OBJS)
+
+include $(top_srcdir)/../../../../../../automake/local.am