summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-12-23 18:18:56 +1100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-01-25 08:45:26 +0100
commit2afb22b7e1ebcbe40373ff7e0efae7d207c655a9 (patch)
tree44759efe9374f13200a97e96d91bd9a2b7e5ce2a /c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
parentMAINTAINERS: Add myself to Write After Approval. (diff)
downloadrtems-2afb22b7e1ebcbe40373ff7e0efae7d207c655a9.tar.bz2
Remove make preinstall
A speciality of the RTEMS build system was the make preinstall step. It copied header files from arbitrary locations into the build tree. The header files were included via the -Bsome/build/tree/path GCC command line option. This has at least seven problems: * The make preinstall step itself needs time and disk space. * Errors in header files show up in the build tree copy. This makes it hard for editors to open the right file to fix the error. * There is no clear relationship between source and build tree header files. This makes an audit of the build process difficult. * The visibility of all header files in the build tree makes it difficult to enforce API barriers. For example it is discouraged to use BSP-specifics in the cpukit. * An introduction of a new build system is difficult. * Include paths specified by the -B option are system headers. This may suppress warnings. * The parallel build had sporadic failures on some hosts. This patch removes the make preinstall step. All installed header files are moved to dedicated include directories in the source tree. Let @RTEMS_CPU@ be the target architecture, e.g. arm, powerpc, sparc, etc. Let @RTEMS_BSP_FAMILIY@ be a BSP family base directory, e.g. erc32, imx, qoriq, etc. The new cpukit include directories are: * cpukit/include * cpukit/score/cpu/@RTEMS_CPU@/include * cpukit/libnetworking The new BSP include directories are: * bsps/include * bsps/@RTEMS_CPU@/include * bsps/@RTEMS_CPU@/@RTEMS_BSP_FAMILIY@/include There are build tree include directories for generated files. The include directory order favours the most general header file, e.g. it is not possible to override general header files via the include path order. The "bootstrap -p" option was removed. The new "bootstrap -H" option should be used to regenerate the "headers.am" files. Update #3254.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am31
1 files changed, 3 insertions, 28 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
index 8196c9d2af..96ec40e15f 100644
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
@@ -10,20 +10,12 @@ endif
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
-include_bspdir = $(includedir)/bsp
+dist_project_lib_DATA = startup/bsp_specs
-dist_project_lib_DATA = bsp_specs
-
-include_HEADERS = include/bsp.h
-include_HEADERS += include/tm27.h
-
-nodist_include_HEADERS = include/bspopts.h
-nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
DISTCLEANFILES = include/bspopts.h
noinst_PROGRAMS =
-include_HEADERS += ../../powerpc/shared/include/nvram.h
EXTRA_DIST += ../../powerpc/shared/start/start.S
start.$(OBJEXT): ../../powerpc/shared/start/start.S
@@ -40,8 +32,8 @@ vectors_entry.$(OBJEXT): ../../powerpc/shared/start/vectors_entry.S
$(CPPASCOMPILE) -o $@ -c $<
project_lib_DATA += vectors_entry.$(OBJEXT)
+project_lib_DATA += linkcmds
dist_project_lib_DATA += ../shared/startup/linkcmds.share
-dist_project_lib_DATA += startup/linkcmds
noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES =
@@ -67,9 +59,6 @@ libbsp_a_SOURCES += ../../shared/tod.c ../../powerpc/shared/tod/todcfg.c
# pclock
libbsp_a_SOURCES += ../../powerpc/shared/clock/p_clock.c
-include_bsp_HEADERS = ../../powerpc/shared/console/consoleIo.h
-include_bsp_HEADERS += ../../powerpc/shared/console/uart.h
-
# Needs conditional compilation
polledIO_CPPFLAGS = -DSTATIC_LOG_ALLOC
noinst_PROGRAMS += polledIO.rel
@@ -84,25 +73,20 @@ libbsp_a_SOURCES += ../../powerpc/shared/console/consoleIo.h
libbsp_a_SOURCES += ../../powerpc/shared/console/keyboard.h
libbsp_a_SOURCES += ../../powerpc/shared/console/uart.h
-include_bsp_HEADERS += include/bsp/irq.h
-
# irq
libbsp_a_SOURCES += ../../powerpc/shared/irq/irq_init.c
libbsp_a_SOURCES += ../../powerpc/shared/irq/openpic_i8259_irq.c
libbsp_a_SOURCES += ../../powerpc/shared/irq/i8259.c
-include_bsp_HEADERS += ../../powerpc/shared/motorola/motorola.h
# motorola
libbsp_a_SOURCES += ../../powerpc/shared/motorola/motorola.h
libbsp_a_SOURCES += ../../powerpc/shared/motorola/motorola.c
-include_bsp_HEADERS += ../../powerpc/shared/openpic/openpic.h
# openpic
libbsp_a_SOURCES += ../../powerpc/shared/openpic/openpic.h
libbsp_a_SOURCES += ../../powerpc/shared/openpic/openpic.c
libbsp_a_SOURCES += ../../powerpc/shared/openpic/openpic.h
-include_bsp_HEADERS += ../../powerpc/shared/pci/pci.h
# pci
libbsp_a_SOURCES += ../../powerpc/shared/pci/pci.c
libbsp_a_SOURCES += ../../powerpc/shared/pci/detect_raven_bridge.c
@@ -110,20 +94,11 @@ libbsp_a_SOURCES += ../../powerpc/shared/pci/generic_clear_hberrs.c
libbsp_a_SOURCES += ../../powerpc/shared/pci/pcifinddevice.c
libbsp_a_SOURCES += ../../powerpc/shared/pci/pci.h
-include_bsp_HEADERS += ../../powerpc/shared/residual/residual.h \
- ../../powerpc/shared/residual/pnp.h
# residual
libbsp_a_SOURCES += ../../powerpc/shared/residual/pnp.h
libbsp_a_SOURCES += ../../powerpc/shared/residual/residual.h
libbsp_a_SOURCES += ../../powerpc/shared/residual/residual.c
-include_bsp_HEADERS += ../../shared/vmeUniverse/vmeUniverse.h \
- ../../shared/vmeUniverse/vme_am_defs.h \
- ../../shared/vmeUniverse/VME.h \
- include/bsp/VMEConfig.h \
- ../../shared/vmeUniverse/vmeUniverseDMA.h\
- ../../shared/vmeUniverse/bspVmeDmaList.h\
- ../../shared/vmeUniverse/VMEDMA.h
# vme
libbsp_a_SOURCES += ../../shared/vmeUniverse/vmeUniverse.c
libbsp_a_SOURCES += ../../shared/vmeUniverse/bspVmeDmaList.c
@@ -169,6 +144,6 @@ EXTRA_DIST += BOOTING README.mtx603e README.MVME2100 README.MVME2300 \
EXTRA_DIST += README.dec21140
EXTRA_DIST += times.mcp750 times.mvme2307
-include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../../automake/local.am
include $(top_srcdir)/../../../../automake/subdirs.am
+include $(srcdir)/../../../../../../bsps/powerpc/motorola_powerpc/headers.am