summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 23:56:57 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 23:56:57 +0000
commit65e6a0f58e81bf0124349edec02e49f0a8824d54 (patch)
treee44304d78b946e661179a54750c6043c5f33fe02 /c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-65e6a0f58e81bf0124349edec02e49f0a8824d54.tar.bz2
2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, ide/Makefile.am, irq/Makefile.am, network/Makefile.am, startup/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, ide/Makefile.am, irq/Makefile.am, network/Makefile.am, startup/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
index d90cb8a605..d893cef875 100644
--- a/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
@@ -2,16 +2,15 @@
## $Id$
##
-# We only build the networking device driver if HAS_NETWORKING was defined
+OBJS = ../pclock$(LIB_VARIANT).rel ../irq$(LIB_VARIANT).rel \
+ ../ide$(LIB_VARIANT).rel ../startup$(LIB_VARIANT).rel \
+ ../console$(LIB_VARIANT).rel ../vectors$(LIB_VARIANT).rel
if HAS_NETWORKING
-NETWORKING = network
+OBJS += ../network$(LIB_VARIANT).rel
endif
-BSP_PIECES = clock irq ide startup console vectors $(NETWORKING)
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- $(wildcard ../../../../libcpu/$(RTEMS_CPU)/shared/*/$(ARCH)/*.$(OBJEXT)) \
+OBJS += ../../../../libcpu/powerpc/shared/cpuIdent$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/shared/cache$(LIB_VARIANT).rel \
../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
../../../../libcpu/powerpc/mpc8xx/clock$(LIB_VARIANT).rel \
../../../../libcpu/powerpc/mpc8xx/console-generic$(LIB_VARIANT).rel \