summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:34 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:34 +0000
commit283dd51021e92a23354eca4dc5588b92f2dc631f (patch)
treeab1ea36f2d7f87b1a9810598b2dbf54845c599f2 /c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
parent2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-283dd51021e92a23354eca4dc5588b92f2dc631f.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS. * irq/Makefile.am: Add PREINSTALL_DIRS. * vectors/Makefile.am: Add PREINSTALL_DIRS. * wrapup/Makefile.am: Reflect changes to libcpu.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
index 5547db59c6..9072f1766a 100644
--- a/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mbx8xx/wrapup/Makefile.am
@@ -8,15 +8,17 @@ NETWORKING = network
endif
BSP_PIECES = clock irq ide startup console vectors $(NETWORKING)
-# pieces to pick up out of libcpu/ppc
-# CPU_PIECES = mpc8xx/clock mpc8xx/console-generic mpc8xx/cpm \
-# mpc8xx/mmu mpc8xx/timer mpc8xx/vectors
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
$(wildcard ../../../../libcpu/$(RTEMS_CPU)/shared/*/$(ARCH)/*.$(OBJEXT)) \
- ../@exceptions@/$(ARCH)/rtems-cpu.rel $(wildcard \
- ../../../../libcpu/$(RTEMS_CPU)/mpc8xx/*/$(ARCH)/*.$(OBJEXT))
+ ../@exceptions@/$(ARCH)/rtems-cpu.rel \
+ ../../../../libcpu/powerpc/mpc8xx/clock$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/mpc8xx/console-generic$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/mpc8xx/cpm$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/mpc8xx/mmu$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/mpc8xx/timer$(LIB_VARIANT).rel \
+ ../../../../libcpu/powerpc/mpc8xx/exceptions$(LIB_VARIANT).rel
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am