summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-17 12:51:46 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-17 12:51:46 +0000
commit0d3876ba15304be69b6dea0013e0111846aa7bb0 (patch)
tree03f9cc9bfbedacde7dfd8d2f78123086e76721cb /c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am
parent2002-12-17 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-0d3876ba15304be69b6dea0013e0111846aa7bb0.tar.bz2
2002-12-17 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am: Don't include @RTEMS_BSP@.cfg. * console/Makefile.am: Don't include @RTEMS_BSP@.cfg. * irq/Makefile.am: Don't include @RTEMS_BSP@.cfg. Remove SORDID_HACK. Eliminate *_O_FILES. * network/Makefile.am: Don't include @RTEMS_BSP@.cfg. * startup/Makefile.am: Don't include @RTEMS_BSP@.cfg. * vectors/Makefile.am: Don't include @RTEMS_BSP@.cfg.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am b/c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am
index 5f4327f869..3bfa168c94 100644
--- a/c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mbx8xx/irq/Makefile.am
@@ -4,24 +4,17 @@
C_FILES = irq.c irq_init.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
include_bspdir = $(includedir)/bsp
include_bsp_HEADERS = irq.h
S_FILES = irq_asm.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
+OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
-OBJS = $(C_O_FILES) $(S_O_FILES)
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
-#HACK: WTF is this?
-SORDID_HACK:
- rm -f $(PROJECT_INCLUDE)/bsp/irq.h
-
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -43,7 +36,7 @@ $(PGM): $(OBJS)
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-all-local: SORDID_HACK $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(PGM)
+all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(PGM)
EXTRA_DIST = irq.c irq_asm.S irq_init.c