summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-19 14:27:24 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-19 14:27:24 +0000
commitd4f9cef5402556a804ae4b37eb45b389e3b08318 (patch)
tree361fc954e6f5fa612b69a627578ea434440be052 /c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am
parent2001-06-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d4f9cef5402556a804ae4b37eb45b389e3b08318.tar.bz2
2001-06-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add bspopts.h. * include/.cvsignore: Add bspopts.h*, stamp-h*. * include/Makefile.am: Use *_HEADERS instead of *H_FILES. * include/bsp.h: Include bspopts.h.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am23
1 files changed, 7 insertions, 16 deletions
diff --git a/c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am b/c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am
index 6728c6032c..5aa1d41035 100644
--- a/c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mbx8xx/include/Makefile.am
@@ -4,9 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = bsp.h coverhd.h
+include_bspdir = $(includedir)/bsp
-BSP_H_FILES = mbx.h commproc.h 8xx_immap.h
+include_HEADERS = bsp.h coverhd.h bspopts.h
+include_bsp_HEADERS = mbx.h commproc.h 8xx_immap.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -14,25 +15,15 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/bsp:
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/bsp.h: bsp.h
+$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-$(PROJECT_INCLUDE)/coverhd.h: coverhd.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/mbx.h : mbx.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/commproc.h : commproc.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/bsp/8xx_immap.h : 8xx_immap.h
+$(PROJECT_INCLUDE)/bsp/%.h : %.h
$(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp \
- $(PROJECT_INCLUDE)/bsp.h \
- $(PROJECT_INCLUDE)/coverhd.h $(PROJECT_INCLUDE)/bsp/mbx.h \
- $(PROJECT_INCLUDE)/bsp/commproc.h $(PROJECT_INCLUDE)/bsp/8xx_immap.h
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%) \
+ $(include_bsp_HEADERS:%=$(PROJECT_INCLUDE)/bsp/%)
all-local: $(PREINSTALL_FILES)