summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:49 +0000
commit9fce0fded1f02efd715b4e1b461d3c0af922f592 (patch)
treed4a2541f0f42fbd7cad776c18b2fa35e57cf2d0f /c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
parent2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-9fce0fded1f02efd715b4e1b461d3c0af922f592.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS. * wrapup/Makefile.am: Reflect changes to libcpu.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
index 4ff25f2fdb..aa69624c7a 100644
--- a/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
@@ -4,12 +4,15 @@
BSP_PIECES = startup dlentry flashentry
# pieces to pick up out of libcpu/ppc
-CPU_PIECES = clock timer console vectors ictrl
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../@exceptions@/$(ARCH)/rtems-cpu.rel $(foreach piece, $(CPU_PIECES), \
- ../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(piece)/$(ARCH)/$(piece).rel)
+ ../@exceptions@/$(ARCH)/rtems-cpu.rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/clock$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/timer$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/console$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/vectors$(LIB_VARIANT).rel \
+ ../../../../libcpu/@RTEMS_CPU@/ppc403/ictrl$(LIB_VARIANT).rel
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am