summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-05 06:14:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-05 06:14:08 +0000
commit641194760114279c1665f9a6b214b452236eaa83 (patch)
tree47f9fcbc0eebaef75c305eac32bbc579f5810fa1 /c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
parent2003-12-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-641194760114279c1665f9a6b214b452236eaa83.tar.bz2
2004-01-05 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* wrapup/Makefile.am: Eliminate $(LIB). Use noinst_DATA to trigger building libbsp.a.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
index 7bb3b94afe..4ff25f2fdb 100644
--- a/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/helas403/wrapup/Makefile.am
@@ -11,18 +11,12 @@ OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
../@exceptions@/$(ARCH)/rtems-cpu.rel $(foreach piece, $(CPU_PIECES), \
../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(piece)/$(ARCH)/$(piece).rel)
-LIB = $(ARCH)/libbsp.a
-
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(LIB): $(OBJS)
+$(ARCH)/libbsp.a: $(OBJS)
$(make-library)
-all-local: $(LIB)
+noinst_DATA = $(ARCH)/libbsp.a
include $(top_srcdir)/../../../../automake/local.am