summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-03-11 17:50:27 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-03-14 10:56:47 +0100
commitf88da30ee8ef1c76410b0fb0fe048a821fd0054e (patch)
tree50af95124ca3857f89b06fa93e3c2f6822200b53 /c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
parentmpc83xx: Copy nothing if necessary (diff)
downloadrtems-f88da30ee8ef1c76410b0fb0fe048a821fd0054e.tar.bz2
mpc83xx: Use shared linkcmds.base
Diffstat (limited to 'c/src/lib/libbsp/powerpc/gen83xx/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/gen83xx/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am b/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
index 7d970ae7fa..f32c299bc6 100644
--- a/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen83xx/Makefile.am
@@ -18,6 +18,8 @@ include_bsp_HEADERS += ../../shared/include/irq-generic.h
include_bsp_HEADERS += ../../shared/include/irq-info.h
include_bsp_HEADERS += ../../shared/include/u-boot.h
include_bsp_HEADERS += ../../shared/include/utility.h
+include_bsp_HEADERS += ../shared/include/linker-symbols.h
+include_bsp_HEADERS += ../shared/include/start.h
include_bsp_HEADERS += ../shared/include/tictac.h
include_bsp_HEADERS += ../shared/include/u-boot-board-info.h
include_bsp_HEADERS += include/hwreg_vals.h
@@ -39,7 +41,8 @@ libbspstart_a_SOURCES += ../../powerpc/shared/start/rtems_crti.S
project_lib_DATA += rtems_crti.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds \
- startup/linkcmds.base \
+ ../shared/startup/linkcmds.base \
+ startup/linkcmds.mpc83xx \
startup/linkcmds.mpc8309som \
startup/linkcmds.mpc8313erdb \
startup/linkcmds.br_uid \
@@ -49,9 +52,6 @@ dist_project_lib_DATA += startup/linkcmds \
noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
-# mpc83xx_regs
-libbsp_a_SOURCES += startup/mpc83xx_regs.c
-
# startup
libbsp_a_SOURCES += ../../shared/bsplibc.c \
../../shared/bsppost.c \