summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-06 16:54:31 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-06 16:54:31 +0000
commitf3d07e5db539e0a174b1fdc5d31a4c4d69ad87d6 (patch)
tree2cc1b1509e84b82742998f4613431efcdbe1d03b /c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
parent2004-02-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f3d07e5db539e0a174b1fdc5d31a4c4d69ad87d6.tar.bz2
2004-02-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* wrapup/Makefile.am: Convert to automake-building rules.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
index c38d8532d7..62ed35bbf9 100644
--- a/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen405/wrapup/Makefile.am
@@ -2,9 +2,16 @@
## $Id$
##
-OBJS = ../startup$(LIB_VARIANT).rel ../dlentry$(LIB_VARIANT).rel
+include $(top_srcdir)/../../../../automake/compile.am
+
+EXTRA_LIBRARIES = ../libbsp.a
+CLEANFILES = ../libbsp.a
+___libbsp_a_SOURCES =
+
+___libbsp_a_LIBADD = ../startup$(LIB_VARIANT).rel \
+ ../dlentry$(LIB_VARIANT).rel
-OBJS += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
+___libbsp_a_LIBADD += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/ppc403/clock$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/ppc403/timer$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/ppc403/console$(LIB_VARIANT).rel \
@@ -12,12 +19,11 @@ OBJS += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/ppc403/vectors$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/ppc403/ictrl$(LIB_VARIANT).rel
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-$(ARCH)/libbsp.a: $(OBJS)
- $(make-library)
+EXTRA_LIBRARIES += ../libbsp_g.a
+CLEANFILES += ../libbsp_g.a
+___libbsp_g_a_SOURCES = $(___libbsp_a_SOURCES)
+___libbsp_g_a_LIBADD = $(___libbsp_a_LIBADD)
-noinst_DATA = $(ARCH)/libbsp.a
+noinst_DATA = ../libbsp$(LIB_VARIANT).a
include $(top_srcdir)/../../../../automake/local.am