summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 16:43:12 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 16:43:12 +0000
commit1d90b6d1cd8861edfeaf677178ccc139a7d29240 (patch)
tree39030912720f1fda543d44d206758865e19d8196 /c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1d90b6d1cd8861edfeaf677178ccc139a7d29240.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in dlentry/Makefile.am, startup/Makefile.am. Use automake compilation rules. * dlentry/Makefile.am, startup/Makefile.am: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am49
1 files changed, 0 insertions, 49 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
deleted file mode 100644
index 301b277a1b..0000000000
--- a/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-##
-## $Id$
-##
-
-PGM = $(ARCH)/startup.rel
-
-C_FILES = bspclean.c bspstart.c setvec.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-shared_C_FILES = $(top_srcdir)/../../shared/bootcard.c
-shared_C_FILES += $(top_srcdir)/../../shared/bsplibc.c
-shared_C_FILES += $(top_srcdir)/../../shared/bsppost.c
-shared_C_FILES += $(top_srcdir)/../../shared/main.c
-shared_C_FILES += $(top_srcdir)/../../shared/sbrk.c
-shared_C_FILES += $(top_srcdir)/../../shared/gnatinstallhandler.c
-OBJS += \
- $(shared_C_FILES:$(top_srcdir)/../../shared/%.c=$(ARCH)/%.$(OBJEXT))
-
-$(ARCH)/%.$(OBJEXT): $(top_srcdir)/../../shared/%.c $(ARCH)/$(dirstamp)
- ${COMPILE} -o $@ -c $<
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-project_lib_DATA = linkcmds
-
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-
-all-local: $(PGM) $(TMPINSTALL_FILES)
-
-EXTRA_DIST = bspclean.c bspstart.c linkcmds linkcmds.dl setvec.c
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am