summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:00 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:00 +0000
commit11a4a3b28309aad4031127c74bd20c81fa54e33f (patch)
treeae77092f09835e297a6806fbad9b4eb674180344 /c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
parent2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-11a4a3b28309aad4031127c74bd20c81fa54e33f.tar.bz2
2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* startup/Makefile.am: Misc cleanups and fixes. * startup/linkcmds: Preparations to gcc-3.3.x. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
index a52f1ccb58..2c33a3ead5 100644
--- a/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen405/startup/Makefile.am
@@ -22,18 +22,16 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+project_lib_DATA = linkcmds
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspclean.c bspstart.c linkcmds linkcmds.dl setvec.c
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am