summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/gen405/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 03:31:07 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 03:31:07 +0000
commit5133bd66b7719450ad360d0e2a55a6d863a51818 (patch)
tree8991da9ed8b6a8880f2e0d5311f30b0107222ae0 /c/src/lib/libbsp/powerpc/gen405/Makefile.am
parent2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-5133bd66b7719450ad360d0e2a55a6d863a51818.tar.bz2
2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org>
* Makefile.am: Merge-in wrapup/Makefile.am. * wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/gen405/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/gen405/Makefile.am b/c/src/lib/libbsp/powerpc/gen405/Makefile.am
index 6b13d1cf31..aacd99312f 100644
--- a/c/src/lib/libbsp/powerpc/gen405/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/gen405/Makefile.am
@@ -4,10 +4,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . @exceptions@ wrapup
-
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
@@ -38,6 +34,19 @@ dlentry_rel_SOURCES = dlentry/dlentry.S
dlentry_rel_CPPFLAGS = $(AM_CPPFLAGS)
dlentry_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES =
+
+libbsp_a_LIBADD = startup.rel dlentry.rel
+
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/@exceptions@/rtems-cpu.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/clock.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/timer.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/console.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/tty_drv.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/vectors.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/ictrl.rel
+
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times