summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 15:59:23 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 15:59:23 +0000
commit5466140831377302760358353a2fc7e84ceb234d (patch)
tree80c5a32b9a2ca87328e687b3da1d06a020b8417c /c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5466140831377302760358353a2fc7e84ceb234d.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in canbus/Makefile.am, clock/Makefile.am, console/Makefile.am, irq/Makefile.am, network/Makefile.am, startup/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * canbus/Makefile.am, clock/Makefile.am, console/Makefile.am, irq/Makefile.am, network/Makefile.am, startup/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am
index 38bd27a564..4260f145d3 100644
--- a/c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/eth_comm/wrapup/Makefile.am
@@ -2,19 +2,13 @@
## $Id$
##
-# We only build the networking device driver if HAS_NETWORKING was defined
+OBJS = ../startup$(LIB_VARIANT).rel ../canbus$(LIB_VARIANT).rel \
+ ../console$(LIB_VARIANT).rel ../irq$(LIB_VARIANT).rel \
+ ../pclock$(LIB_VARIANT).rel ../vectors$(LIB_VARIANT).rel
if HAS_NETWORKING
-NETWORKING = network
+OBJS += ../network$(LIB_VARIANT).rel
endif
-
-BSP_PIECES = clock irq startup start canbus vectors console $(NETWORKING)
-# pieces to pick up out of libcpu/ppc
-# CPU_PIECES = mpc860/clock mpc860/timer mpc860/console-generic \
-# mpc860/vectors
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../../../../libcpu/@RTEMS_CPU@/shared/cpuIdent$(LIB_VARIANT).rel \
+OBJS += ../../../../libcpu/@RTEMS_CPU@/shared/cpuIdent$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/shared/cache$(LIB_VARIANT).rel \
../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/clock$(LIB_VARIANT).rel \