summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/eth_comm/clock/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-04-16 20:18:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-04-16 20:18:03 +0000
commit4055e6f86f2649e40e5f3a49c3c5459e55e57002 (patch)
tree72013f4ad7ef0c816fba7aef32efac0227f3f02d /c/src/lib/libbsp/powerpc/eth_comm/clock/Makefile.am
parent2001-04-16 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-4055e6f86f2649e40e5f3a49c3c5459e55e57002.tar.bz2
2001-04-11 Eric Valette <valette@crf.canon.fr>
* clock/.cvsignore, clock/Makefile.am, clock/p_clock.c, include/8xx_immap.h, include/commproc.h, irq/.cvsignore, irq/Makefile.am, irq/irq.c, irq/irq.h, irq/irq_asm.S, irq/irq_init.c, vectors/.cvsignore, vectors/Makefile.am, vectors/vectors.S, vectors/vectors.h, vectors/vectors_init.c: New file. * Switch the eth_comm BSP to use the "new exception processing model."
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/eth_comm/clock/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/eth_comm/clock/Makefile.am b/c/src/lib/libbsp/powerpc/eth_comm/clock/Makefile.am
new file mode 100644
index 0000000000..c41be0decc
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/eth_comm/clock/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../shared/clock
+
+C_FILES = p_clock.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS)
+
+include $(top_srcdir)/../../../../../../automake/local.am