summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 17:12:37 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 17:12:37 +0000
commitfb6b168f61f86e9968df36cb4d3f52d1de8815e8 (patch)
treebb62503697dd94521ef2ccefba0833a4bbe9f8fc /c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-fb6b168f61f86e9968df36cb4d3f52d1de8815e8.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, scv64/Makefile.am, sonic/Makefile.am, start/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, scv64/Makefile.am, sonic/Makefile.am, start/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am: Remove. * configure.ac, wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am
index 47ac70db9c..59d850bd99 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/dmv177/wrapup/Makefile.am
@@ -2,17 +2,13 @@
## $Id$
##
-# We only build the networking device driver if HAS_NETWORKING was defined
+OBJS = ../startup$(LIB_VARIANT).rel ../clock$(LIB_VARIANT).rel \
+ ../console$(LIB_VARIANT).rel ../scv64$(LIB_VARIANT).rel \
+ ../timer$(LIB_VARIANT).rel ../tod$(LIB_VARIANT).rel
if HAS_NETWORKING
-NETWORKING = sonic
+OBJS += ../sonic$(LIB_VARIANT).rel
endif
-# pieces specific to this BSP
-BSP_PIECES = startup clock console scv64 timer tod $(NETWORKING)
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), \
- ../$(piece)/$(ARCH)/*.$(OBJEXT))
OBJS += ../@exceptions@/rtems-cpu$(LIB_VARIANT).rel \
../../../../libcpu/@RTEMS_CPU@/shared/cache$(LIB_VARIANT).rel