summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am b/c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am
new file mode 100644
index 0000000000..2302aeeecb
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/dmv177/include/Makefile.am
@@ -0,0 +1,33 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h ../../../shared/include/coverhd.h dmv170.h \
+ ../../../shared/tod.h
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/bsp.h: bsp.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/dmv170.h: dmv170.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/tod.h: ../../../shared/tod.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
+ $(PROJECT_INCLUDE)/coverhd.h $(PROJECT_INCLUDE)/dmv170.h \
+ $(PROJECT_INCLUDE)/tod.h
+
+all-local: $(TMPINSTALL_FILES)
+
+EXTRA_DIST = bsp.h dmv170.h
+
+include $(top_srcdir)/../../../../../../automake/local.am