summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-22 16:09:15 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-22 16:09:15 +0000
commitde2b815ffbf8e30b0de4e7188c4966070cdc3115 (patch)
treee50f9fac6bce8bed8b31c51db9b279284b94301b /c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am
parent2003-12-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-de2b815ffbf8e30b0de4e7188c4966070cdc3115.tar.bz2
2003-12-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am: Eliminate VPATH. * console/Makefile.am: Eliminate VPATH. * scv64/Makefile.am: Eliminate VPATH. * sonic/Makefile.am: Eliminate VPATH. * start/Makefile.am: Eliminate VPATH. * startup/Makefile.am: Eliminate VPATH. * timer/Makefile.am: Eliminate VPATH. * tod/Makefile.am: Eliminate VPATH.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am27
1 files changed, 8 insertions, 19 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am b/c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am
index 3074b7e017..d1fa1a27fd 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/dmv177/console/Makefile.am
@@ -2,31 +2,20 @@
## $Id$
##
-VPATH = @srcdir@:@srcdir@/../../../shared
-
-PGM = $(ARCH)/console.rel
-
-C_FILES = conscfg.c console.c debugio.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES)
+C_FILES = conscfg.c debugio.c
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+shared_C_FILES = $(top_srcdir)/../../shared/console.c
+OBJS += $(shared_C_FILES:$(top_srcdir)/../../shared/%.c=$(ARCH)/%.$(OBJEXT))
-all-local: $(OBJS) $(PGM)
+$(ARCH)/%.$(OBJEXT): $(top_srcdir)/../../shared/%.c $(ARCH)/$(dirstamp)
+ ${COMPILE} -o $@ -c $<
-.PRECIOUS: $(PGM)
+noinst_DATA = $(OBJS)
-EXTRA_DIST = conscfg.c debugio.c
+EXTRA_DIST = $(C_FILES)
include $(top_srcdir)/../../../../automake/local.am