summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 12:23:14 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 12:23:14 +0000
commita692823e787f34cc6faf03bb604ae237afc04c02 (patch)
treeae2d6ba04bf7d5393d06d806092a42aecf91ce2c /c/src/lib/libbsp/powerpc/dmv177/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a692823e787f34cc6faf03bb604ae237afc04c02.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/dmv177/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/dmv177/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/dmv177/Makefile.am b/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
index c6bd492750..8e3c295a94 100644
--- a/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/dmv177/Makefile.am
@@ -5,13 +5,31 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include clock console startup start timer scv64 tod sonic \
- @exceptions@ wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . clock console startup start timer scv64 tod sonic @exceptions@ \
+ wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = QUIRKS README.net STATUS bsp_specs cable.doc times
+include_HEADERS += include/dmv170.h
+nodist_include_HEADERS += $(top_srcdir)/../../shared/tod.h
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = QUIRKS README.net STATUS cable.doc times
+
+$(PROJECT_INCLUDE)/dmv170.h: include/dmv170.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/dmv170.h
+
+$(PROJECT_INCLUDE)/tod.h: $(top_srcdir)/../../shared/tod.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/tod.h
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am