summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or32/orp/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-06 13:57:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-06 13:57:03 +0000
commita24d946fc0e2420a93cc80fe3965d617251df2ba (patch)
tree0b63e2efb981b29ef0d3e009c0f9f9c532e3e0dd /c/src/lib/libbsp/or32/orp/wrapup/Makefile.am
parent2002-08-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a24d946fc0e2420a93cc80fe3965d617251df2ba.tar.bz2
2002-08-06 Chris Ziomkowski <chris@asics.ws>
* .cvsignore, Makefile.am, README, bsp_specs, configure.ac, times, clock/.cvsignore, clock/Makefile.am, clock/clockdrv.c, console/.cvsignore, console/Makefile.am, console/console.c, console/console.h, include/.cvsignore, include/Makefile.am, include/bsp.h, start/.cvsignore, start/Makefile.am, start/start.S, startup/.cvsignore, startup/bspclean.c, startup/bspstart.c, startup/linkcmds, startup/main.c, startup/setvec.c, timer/.cvsignore, timer/Makefile.am, timer/timer.c, timer/timerisr.c, wrapup/.cvsignore, wrapup/Makefile.am, ChangeLog: New files added as part of merge from OpenCores repository.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/or32/orp/wrapup/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/or32/orp/wrapup/Makefile.am b/c/src/lib/libbsp/or32/orp/wrapup/Makefile.am
new file mode 100644
index 0000000000..d094f1281b
--- /dev/null
+++ b/c/src/lib/libbsp/or32/orp/wrapup/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+BSP_FILES = startup clock console timer
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+# bummer; have to use $foreach since % pattern subst rules only replace 1x
+OBJS = $(foreach piece, $(BSP_FILES), $(wildcard ../$(piece)/$(ARCH)/*.o)) \
+ $(wildcard ../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(ARCH)/*.o) \
+ $(foreach piece, $(GENERIC_FILES), ../../../$(piece)/$(ARCH)/$(piece).rel)
+
+LIB = $(ARCH)/libbsp.a
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): ${OBJS}
+ $(make-library)
+
+all-local: ${ARCH} $(LIB)
+
+include $(top_srcdir)/../../../../../../automake/local.am