summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
diff options
context:
space:
mode:
authorHesham ALMatary <heshamelmatary@gmail.com>2014-08-22 15:22:37 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-08-25 11:13:55 -0500
commitbaa3c91ecb8a3b48ef387b938fcdb6e60b5bdc8a (patch)
tree7391de2d16ccc52776e7d47703c7201d365a5480 /c/src/lib/libbsp/or1k/or1ksim/Makefile.am
parentAdd or1k to the list of targets that use IEEE 754 in xdr_float.c (diff)
downloadrtems-baa3c91ecb8a3b48ef387b938fcdb6e60b5bdc8a.tar.bz2
or1ksim BSP: Include cache manager stubs, and re-generate preinstall.am files.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/or1k/or1ksim/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/or1k/or1ksim/Makefile.am b/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
index d5eb10c28e..f1315c404a 100644
--- a/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
+++ b/c/src/lib/libbsp/or1k/or1ksim/Makefile.am
@@ -9,7 +9,7 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
include $(top_srcdir)/../../../../automake/compile.am
include_bspdir = $(includedir)/bsp
-#include_libcpudir = $(includedir)/libcpu
+include_libcpudir = $(includedir)/libcpu
dist_project_lib_DATA = bsp_specs
@@ -21,7 +21,6 @@ include_bsp_HEADERS =
include_HEADERS = include/bsp.h
nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
-
include_bsp_HEADERS += ../shared/include/linker-symbols.h
include_bsp_HEADERS += ../../../libbsp/shared/include/mm.h
include_bsp_HEADERS += ../../shared/include/utility.h
@@ -99,6 +98,12 @@ libbsp_a_SOURCES += ../../shared/src/irq-default-handler.c
libbsp_a_SOURCES += ../../shared/src/irq-generic.c
libbsp_a_SOURCES += ../../shared/src/irq-info.c
libbsp_a_SOURCES += irq/irq.c
+
+# Cache
+libbsp_a_SOURCES += ../../../libcpu/shared/src/cache_manager.c
+libbsp_a_SOURCES += ../../shared/include/cache_.h
+libbsp_a_CPPFLAGS = -I$(srcdir)/../../shared/include
+
###############################################################################
# Special Rules #
###############################################################################