summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:04:49 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:04:49 +0000
commit1e562da69e0186dc27766f884b0f247df3baea98 (patch)
tree76c9834ee56cfb3117cd2df8815e8c49ae38cd8c /c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
parentPatch rtems-rc-20000104-4.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1e562da69e0186dc27766f884b0f247df3baea98.tar.bz2
Patch rtems-rc-20000104-5.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the no_cpu directory to automake.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am b/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
new file mode 100644
index 0000000000..124c211820
--- /dev/null
+++ b/c/src/lib/libbsp/no_cpu/no_bsp/console/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/console.rel
+
+## C source names
+C_FILES = console.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am