summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/moxie/moxiesim/Makefile.am
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2013-02-27 13:13:20 -0500
committerGedare Bloom <gedare@rtems.org>2013-02-28 12:24:17 -0500
commit032e5e491544a2184f74e81019ce53c5fb2bb74b (patch)
tree864ab94f5a12ed5344611da898196a048c91d559 /c/src/lib/libbsp/moxie/moxiesim/Makefile.am
parentAdd Moxie CPU support (diff)
downloadrtems-032e5e491544a2184f74e81019ce53c5fb2bb74b.tar.bz2
Add sample Moxie BSP for GDB sim
Signed-off-by: Anthony Green <green@moxielogic.com>
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/moxie/moxiesim/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/moxie/moxiesim/Makefile.am b/c/src/lib/libbsp/moxie/moxiesim/Makefile.am
new file mode 100644
index 0000000000..8b062801c0
--- /dev/null
+++ b/c/src/lib/libbsp/moxie/moxiesim/Makefile.am
@@ -0,0 +1,49 @@
+##
+## $Id: Makefile.am,v 1.36 2008/10/02 21:39:40 joel Exp $
+##
+
+ACLOCAL_AMFLAGS = -I ../../../../aclocal
+
+include $(top_srcdir)/../../../../automake/compile.am
+
+include_bspdir = $(includedir)/bsp
+
+dist_project_lib_DATA = bsp_specs
+
+include_HEADERS = include/bsp.h
+include_HEADERS += ../../shared/include/tm27.h
+
+nodist_include_HEADERS = include/bspopts.h
+nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
+DISTCLEANFILES = include/bspopts.h
+
+nodist_include_HEADERS += ../../shared/include/coverhd.h
+
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = start/start.S
+project_lib_DATA = start.$(OBJEXT)
+
+dist_project_lib_DATA += startup/linkcmds
+
+noinst_LIBRARIES += libbsp.a
+libbsp_a_SOURCES =
+
+# startup
+libbsp_a_SOURCES += ../../shared/bspclean.c ../../shared/bsplibc.c \
+ ../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
+ ../../shared/bspgetworkarea.c ../../shared/bsppost.c \
+ ../../shared/bspstart.c startup/moxiebdinstallirq.c \
+ ../../shared/bootcard.c ../../shared/sbrk.c \
+ ../../shared/gnatinstallhandler.c startup/__main.c
+# clock
+libbsp_a_SOURCES += ../../shared/clock_driver_simidle.c
+# console
+libbsp_a_SOURCES += ../../shared/console-polled.c console/console-io.c \
+ console/syscalls.S
+# timer
+libbsp_a_SOURCES += ../../shared/timerstub.c
+
+EXTRA_DIST = times
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/../../../../automake/local.am