summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 07:56:36 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 07:56:36 +0000
commite06d84537d163fa4847f536f202e4b4e062889c6 (patch)
tree15d60f2c7e60bc5aae5a57d74fa3e466c49ce58f /c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
parent2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e06d84537d163fa4847f536f202e4b4e062889c6.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS. * wrapup/Makefile.am: Reflect changes to libcpu.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am14
1 files changed, 5 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am b/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
index 0db104befd..ec5124e9c0 100644
--- a/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/mips/p4000/wrapup/Makefile.am
@@ -3,21 +3,17 @@
##
BSP_FILES = startup console liblnk
-CPU_FILES = clock timer
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
# bummer; have to use $foreach since % pattern subst rules only replace 1x
OBJS = $(foreach piece, $(BSP_FILES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- $(foreach piece, $(CPU_FILES), $(wildcard \
- ../../../../libcpu/$(RTEMS_CPU)/$(piece)/$(ARCH)/*.$(OBJEXT))) \
- $(wildcard ../../../../libcpu/$(RTEMS_CPU)/shared/*/$(ARCH)/*.$(OBJEXT)) \
- $(wildcard ../../../../libcpu/$(RTEMS_CPU)/r46xx/*/$(ARCH)/*.$(OBJEXT)) \
- $(wildcard \
- ../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(ARCH)/*.$(OBJEXT)) \
- $(foreach piece, $(GENERIC_FILES), \
- ../../../$(piece)/$(ARCH)/$(piece).rel)
+ ../../../../libcpu/mips/shared/cache$(LIB_VARIANT).rel \
+ ../../../../libcpu/mips/shared/interrupts$(LIB_VARIANT).rel \
+ ../../../../libcpu/mips/r46xx/clock$(LIB_VARIANT).rel \
+ ../../../../libcpu/mips/r46xx/timer$(LIB_VARIANT).rel \
+ ../../../../libcpu/mips/r46xx/vectorisrs$(LIB_VARIANT).rel
$(ARCH)/libbsp.a: $(OBJS)
$(make-library)