summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/mips/jmr3904/start/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-25 18:58:05 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-25 18:58:05 +0000
commitc8471315ff9c38541f5623375a85166890788cd7 (patch)
tree205114008dd25aa2bcd78360934da0661ebc0302 /c/src/lib/libbsp/mips/jmr3904/start/Makefile.am
parent2000-11-25 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-c8471315ff9c38541f5623375a85166890788cd7.tar.bz2
2000-11-25 Joel Sherrill <joel@OARcorp.com>
* The JMR BSP is for a Toshiba TX39 evaluation board but can also be used with the mips simulator in gdb. * .cvsignore, ChangeLog, Makefile.am, README, bsp_specs, configure.in, clock/.cvsignore, clock/Makefile.am, clock/clockdrv.c, console/.cvsignore, console/Makefile.am, console/console-io.c, include/.cvsignore, include/Makefile.am, include/bsp.h, start/.cvsignore, start/Makefile.am, start/regs.S, start/start.S, startup/.cvsignore, startup/Makefile.am, startup/bspstart.c, startup/linkcmds, wrapup/.cvsignore, wrapup/Makefile.am: New files.
Diffstat (limited to 'c/src/lib/libbsp/mips/jmr3904/start/Makefile.am')
-rw-r--r--c/src/lib/libbsp/mips/jmr3904/start/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/mips/jmr3904/start/Makefile.am b/c/src/lib/libbsp/mips/jmr3904/start/Makefile.am
new file mode 100644
index 0000000000..86053b9e99
--- /dev/null
+++ b/c/src/lib/libbsp/mips/jmr3904/start/Makefile.am
@@ -0,0 +1,33 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/start.o
+
+S_FILES = start.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(S_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).o: $(PGM)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).o
+
+all-local: $(ARCH) $(OBJS) $(PGM) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = start.S
+
+include $(top_srcdir)/../../../../../../automake/local.am