summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-17 20:27:41 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-17 20:27:41 +0000
commitbeec29b7a9bef2a158bd87c2a4d6d007b23f5cdd (patch)
tree6691174c2872be120576170c7fb343676290a6be /c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am
parent2001-10-17 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-beec29b7a9bef2a158bd87c2a4d6d007b23f5cdd.tar.bz2
2001-10-17 Joel Sherrill <joel@OARcorp.com>
* timer: New subdirectory. * timer/Makefile.am: New file. * timer/.cvsignore: New file. * Makefile.am: Modified to reflect above. * configure.ac: Ditto.
Diffstat (limited to 'c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am b/c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am
new file mode 100644
index 0000000000..7e3394e263
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/sim68000/timer/Makefile.am
@@ -0,0 +1,35 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../../shared
+
+PGM = $(ARCH)/timer.rel
+
+C_FILES = timerstub.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = timer.c
+
+include $(top_srcdir)/../../../../../../automake/local.am