summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme162/tools/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
commitd7aecdc8f866b978a4349b0e157f46877f60e414 (patch)
treedf28b2fa6611df7f1003f57447771edb69275761 /c/src/lib/libbsp/m68k/mvme162/tools/configure.ac
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d7aecdc8f866b978a4349b0e157f46877f60e414.tar.bz2
2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* .cvsignore: Add autom4te.cache for autoconf > 2.52. * configure.in: Remove.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/m68k/mvme162/tools/configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme162/tools/configure.ac b/c/src/lib/libbsp/m68k/mvme162/tools/configure.ac
new file mode 100644
index 0000000000..7d01732c5d
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/mvme162/tools/configure.ac
@@ -0,0 +1,37 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([sload.c])
+RTEMS_TOP(../../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-m68k-mvme162-tools,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+AC_EXEEXT
+
+AC_PROG_CC
+
+## FIXME: The checks below are probably incorrect and will not work for
+## those actually having sys/vme.h
+## Please report any errors related to it, otherwise we will not be able
+## to fix building/configuring sload
+AC_HEADER_STDC
+AC_CHECK_HEADERS(unistd.h sys/vme.h)
+AC_FUNC_MMAP
+
+AM_CONDITIONAL(SLOAD_BUILDABLE,
+test "$ac_cv_header_sys_vme_h" = "yes" \
+-a "$ac_cv_header_unistd_h" = "yes" \
+-a "$ac_cv_header_stdc" = "yes" )
+
+RTEMS_PROJECT_ROOT
+RTEMS_TOOLPATHS
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT