summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-10 12:37:23 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-10 12:37:23 +0000
commit15d7f766c5b4f6d52ffd5721892c8d6c604995c7 (patch)
treefea148829fb3fad4044f534e335b8b1de7c69d27 /c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am
parent2003-12-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-15d7f766c5b4f6d52ffd5721892c8d6c604995c7.tar.bz2
2003-12-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Misc cleanups and fixes. * start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am b/c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am
index ee827af4a4..a9ebdca9cb 100644
--- a/c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme162/startup/Makefile.am
@@ -23,18 +23,16 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+project_lib_DATA = linkcmds
# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = bspclean.c bspstart.c linkcmds page_table.c
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am