summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:29:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:29:44 +0000
commit7068e2465b84ff1561ae556a597efed94c86ec2e (patch)
tree6c3b15d92e07c311b41704fcc54e1056facef39d /c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
parentPatch rtems-rc-20000104-9.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7068e2465b84ff1561ae556a597efed94c86ec2e.tar.bz2
Patch rtems-rc-20000104-10.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the m68k directory to automake. NOTE: This one is fully tested by building *all* bsps with ../../rtems-rc-20000104/configure \ --target=m68k-rtems \ --prefix=/tmp/rtems \ --enable-cxx \ --disable-posix \ --enable-rdbg \ --disable-networking \ --enable-maintainer-mode \ --enable-multiprocessing \ --disable-tests make
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am b/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
new file mode 100644
index 0000000000..7932696f8c
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/mvme136/shmsupp/Makefile.am
@@ -0,0 +1,35 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/shmsupp.rel
+
+## C source names
+C_FILES = addrconv.c getcfg.c lock.c mpisr.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+if HAS_MP
+all-local: ${ARCH} $(PGM)
+else
+all-local:
+endif
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am