summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/mvme136/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-13 17:49:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-13 17:49:08 +0000
commita2df3eaa424cfb3337750232e5b54b8910ae86ea (patch)
tree801bcbd5e50f3828e0fa6207f2c9297b7168cd2c /c/src/lib/libbsp/m68k/mvme136/Makefile.am
parent2004-01-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a2df3eaa424cfb3337750232e5b54b8910ae86ea.tar.bz2
2004-01-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/.cvsignore: Remove. * start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/m68k/mvme136/Makefile.am')
-rw-r--r--c/src/lib/libbsp/m68k/mvme136/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/m68k/mvme136/Makefile.am b/c/src/lib/libbsp/m68k/mvme136/Makefile.am
index 8745a414cb..bd7999c7f7 100644
--- a/c/src/lib/libbsp/m68k/mvme136/Makefile.am
+++ b/c/src/lib/libbsp/m68k/mvme136/Makefile.am
@@ -4,21 +4,34 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . start startup clock console shmsupp timer wrapup
-
-include $(top_srcdir)/../../bsp.am
+SUBDIRS = . startup clock console shmsupp timer wrapup
include_HEADERS += include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+m68k_sharedS_FILES = $(top_srcdir)/../../m68k/shared/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): $(top_srcdir)/../../m68k/shared/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = times
+TMPINSTALL_FILES =
+
$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/coverhd.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+$(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): $(ARCH)/start$(LIB_VARIANT).$(OBJEXT) $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
+
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am