summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 13:46:50 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 13:46:50 +0000
commiteb40b1ce141db0b0774367477ffff5493578682d (patch)
tree8fbb14b39a27c2e644017374689b10e45fbc548a /c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
parent2004-01-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-eb40b1ce141db0b0774367477ffff5493578682d.tar.bz2
2004-01-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, network/Makefile.am, startup/Makefile.am, timer/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, network/Makefile.am, startup/Makefile.am, timer/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am25
1 files changed, 0 insertions, 25 deletions
diff --git a/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am b/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
deleted file mode 100644
index acf1802a8b..0000000000
--- a/c/src/lib/libbsp/m68k/gen68302/wrapup/Makefile.am
+++ /dev/null
@@ -1,25 +0,0 @@
-##
-## $Id$
-##
-
-# We only build the networking device driver if HAS_NETWORKING was defined
-if HAS_NETWORKING
-NETWORKING_DRIVER = network
-endif
-
-BSP_PIECES = startup clock console timer $(NETWORKING_DRIVER)
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../../../../libcpu/@RTEMS_CPU@/shared/cache$(LIB_VARIANT).rel \
- ../../../../libcpu/@RTEMS_CPU@/shared/misc$(LIB_VARIANT).rel
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-$(ARCH)/libbsp.a: $(OBJS)
- $(make-library)
-
-noinst_DATA = $(ARCH)/libbsp.a
-
-include $(top_srcdir)/../../../../automake/local.am