summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/gen68302/network/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-14 17:53:53 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-14 17:53:53 +0000
commit8b868a11d919c746f699dfe45da04214dfae147d (patch)
tree39457e7bab889600e746332a07f3ba3a5586ce98 /c/src/lib/libbsp/m68k/gen68302/network/Makefile.am
parent2000-12-14 Emmanuel Raguet <raguet@crf.canon.fr> (diff)
downloadrtems-8b868a11d919c746f699dfe45da04214dfae147d.tar.bz2
2000-12-11 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, configure.in, include/Makefile.am, wrapup/Makefile.am: Updated to reflect addition of network driver by Franck Julien <FranckJ@cxr.fr>. * include/m302_int.h, network/.cvsignore, network/Makefile.am, network/network.c: New file.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/m68k/gen68302/network/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/gen68302/network/Makefile.am b/c/src/lib/libbsp/m68k/gen68302/network/Makefile.am
new file mode 100644
index 0000000000..82809cccf9
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/gen68302/network/Makefile.am
@@ -0,0 +1,37 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/network.rel
+
+C_FILES = network.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+if HAS_NETWORKING
+all-local: $(ARCH) $(OBJS) $(PGM)
+endif
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = network.c
+
+include $(top_srcdir)/../../../../../../automake/local.am