summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/m68k/dmv152/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:29:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:29:44 +0000
commit7068e2465b84ff1561ae556a597efed94c86ec2e (patch)
tree6c3b15d92e07c311b41704fcc54e1056facef39d /c/src/lib/libbsp/m68k/dmv152/configure.in
parentPatch rtems-rc-20000104-9.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7068e2465b84ff1561ae556a597efed94c86ec2e.tar.bz2
Patch rtems-rc-20000104-10.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the m68k directory to automake. NOTE: This one is fully tested by building *all* bsps with ../../rtems-rc-20000104/configure \ --target=m68k-rtems \ --prefix=/tmp/rtems \ --enable-cxx \ --disable-posix \ --enable-rdbg \ --disable-networking \ --enable-maintainer-mode \ --enable-multiprocessing \ --disable-tests make
Diffstat (limited to 'c/src/lib/libbsp/m68k/dmv152/configure.in')
-rw-r--r--c/src/lib/libbsp/m68k/dmv152/configure.in33
1 files changed, 33 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/m68k/dmv152/configure.in b/c/src/lib/libbsp/m68k/dmv152/configure.in
new file mode 100644
index 0000000000..f33ffbb8a5
--- /dev/null
+++ b/c/src/lib/libbsp/m68k/dmv152/configure.in
@@ -0,0 +1,33 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(bsp_specs)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-m68k-dmv152,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+# Explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+clock/Makefile
+console/Makefile
+include/Makefile
+spurious/Makefile
+start/Makefile
+startup/Makefile
+timer/Makefile
+wrapup/Makefile)