summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i960/rxgen960/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 12:06:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 12:06:49 +0000
commit602610f6364eac5ce602965e92cd176adc9678d6 (patch)
tree647ffbdc32af354a39b9e04fa5b1cbc17e2f83cc /c/src/lib/libbsp/i960/rxgen960/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-602610f6364eac5ce602965e92cd176adc9678d6.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i960/rxgen960/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/i960/rxgen960/Makefile.am b/c/src/lib/libbsp/i960/rxgen960/Makefile.am
index 1d443861bc..f77893b71e 100644
--- a/c/src/lib/libbsp/i960/rxgen960/Makefile.am
+++ b/c/src/lib/libbsp/i960/rxgen960/Makefile.am
@@ -5,12 +5,20 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include start startup clock console timer wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup clock console timer wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+noinst_HEADERS = include/rxgen960_config.h
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am