summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/console/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-19 14:26:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-19 14:26:29 +0000
commit2e45a0cbf44a78ed0421513fd23eda93025f52ce (patch)
tree5bcbce5daa23aac594149fd260e08d86ed01fc2e /c/src/lib/libbsp/i386/pc386/console/Makefile.am
parent2001-06-19 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-2e45a0cbf44a78ed0421513fd23eda93025f52ce.tar.bz2
2001-06-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add bspopts.h. * include/.cvsignore: Add bspopts.h*, stamp-h*. * include/Makefile.am: Use *_HEADERS instead of *H_FILES. * 3c509/Makefile.am: Dito. * console/Makefile.am: Dito. * include/bsp.h: Include bspopts.h.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/pc386/console/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/console/Makefile.am b/c/src/lib/libbsp/i386/pc386/console/Makefile.am
index 1c6fcfb899..91f48b692a 100644
--- a/c/src/lib/libbsp/i386/pc386/console/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/console/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-VPATH = @srcdir@:@srcdir@/../../shared/io
-
PGM = $(ARCH)/console.rel
-RTEMS_H_FILES = keyboard.h kd.h serial_mouse.h ps2_drv.h fb_vga.h
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = keyboard.h kd.h serial_mouse.h ps2_drv.h fb_vga.h
C_FILES = console.c inch.c outch.c defkeymap.c fb_vga.c keyboard.c \
mouse_parser.c pc_keyb.c ps2_mouse.c serial_mouse.c vgainit.c vt.c
@@ -21,7 +20,7 @@ include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
PREINSTALL_FILES += $(PROJECT_INCLUDE) \
- $(RTEMS_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/%.h)
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
#
# (OPTIONAL) Add local stuff here using +=